Addicts Open Thread

Hey Howdy Hey Tappers!

It’s that time of the week again, time for the Addicts Weekly Open Thread!  So, let’s get the conversation going!  Oh and remember…just because this is posted here today doesn’t mean you can’t comment on it all week long.  This open thread will still be open for comments long after today is over!

Here’s where you can talk about anything you want to talk about…TSTO Related, Simpson’s Related or ANYTHING.  Just no Add me requests…those should go here.  We’ll give you a few suggestions (like most Sunday’s you can talk about the current episode of the Simpsons or current Tapped Out event) but for the most part, you’re free to talk about ANYTHING your little Tapping Fingers desire…just keep it PG.

So, here is your Open Thread…..

Lots of things you may have missed this week around the Addicts Site:

Simpsons is off for the summer. But did you catch the 750th episode. Did you catch the episode reminder? What about the new Bracket Battle?

The newest event is about to hit our games this week week. Did you check out Graham’s Rundown post? Looking forward to it?

How’s your Springfield design coming?  What are you doing with your town? Share some photos in the comments below! (If you need a refresher on how to add photos to the comments check out this post)

Any weekend excitement going on in your neck of the woods? Any vacations planned? Check out any new anime shows or anime movies?

So chat about the Simpsons, TSTO, Update fun, or anything else you can think of! (Just no politics, it never ends well)  Can’t wait to chat with you all, you know we love hearing from you!

Have Fun!  And happy Sunday!

40 responses to “Addicts Open Thread

  1. I’ve got an issue. 2 days ago I logged into the game and nearly everything was gone. Nearly all characters and buildings were in inventory. All decorations in inventory. All roads, monorail and piers in inventory. After many attempts to get an answer from ea help I’ve just been told this is a global issue affecting hundreds of thousands of players. I couldn’t find mention of this issue here. Just the can’t connect to server issue. Anyway, help said that they are working on a tool to fix the issue and to wait. Just thought I’d pass this on.

    • Try a quit and restart then log out and log in again to try to recover the game for your account.

      If everything still shows up in inventory contact EA Help directly during US business hours and ask politely but firmly for a Rollback. Using the Phone or Live Chat options are better than emailing them.
      On the options add device and >Lost Content > Had content and lost it.
      If it sends you to Ask the Community look for Still Need Help

      That will take your game back to how it was before the issue so you will lose what you tapped for since but you’ll have time to catch up on the event if you don’t delay.

      • Thanks Graham. I have politely asked each time for a roll back. I explained they’ve done it before. I’ve been using live chat. The last guy was super cagey about timelines. Just be patient he said. They are working on it. I explained time is important to finish the event. I will try a log out but I’m not hopeful I have to say ☹️. Which US business hours? East coast? I’m in New Zealand so I have to work out the time difference 🙂

        • Try 7 to 15 hours earlier than this reply … weekends may work

          • Just tried again to get a roll back. They point blank said it is not possible. I know it’s possible because they did it for me years ago when my game was hacked. They suggested the land was destroyed and it is feature of the game to put it in inventory. They asked me to name all the missing items. They told me to take everything out of inventory. I’m beyond frustrated. I don’t have the time or inclination to replace 10 years of building. Earlier a consultant said this was a global issue. This most recent consultant said the tool was broken which I gather is used to check games and not a fix that was being worked on as was implied. The last consultant actually said there’s nothing we can do and ended the chat.

  2. I need help! Im decorating my town from scratch and my Krustyland just cannot be made into a reasonable size! Currently it takes up about 40% of all main land.

    I have every purschable land and frontier land. I have emtptied the mysterybox and played since early 2022. Please give me tips on how to make areas tighter without becoming cluttered.

    • store things that you don’t love is my advice. My KL is combined with my Mount Splashmore and I&S land. I have it segregated from springfield proper by 2 strips of unpurchased land tiles.

      Don’t surround each individual building with road, instead create blocks of things.

      find my friend request in the other thread for neighbors and check it out for ideas. KL is on the far right & bottom side of my town.

  3. I don’t understand why my comments aren’t showing?

    • LOL, okay this one made it, but I commented twice yesterday about the outage and they didn’t. Sorry for feeling paranoid.

  4. Was find this am.. went to log in 2 hrs ago & got “Cannot connect to server”

    Great.. now Ill have to do some work 😢

  5. Game tries to download the update fir a fraction of a second then goes to ‘cannot reach server’ page
    Trapped in ‘retry” limbo.

    • Mine is also crashing. Can’t get by Bart and the “retry” screen

      Not a fan as i just redid the multiplier so I’m just wasting away

      • Use Recent Apps or Settings to fully close the game then restart it from the icon on your Homescreen

        • Thanks Graham, still in Retry limbo sadly.

        • Tried that and still in Retry hell 🙁

          • One of the AHQ EA Team says they can’t see anything on their end.
            Could it be a provider issue or can you get online OK for other stuff ??

            • I can access everything else online and other apps. Just this one not working. I tried uninstalling the app and then reinstall…would start downloading and get about 80% or so and then go back to Bart’s Retry. Does the countdown…hit retry…Bart pops back up… rinse and repeat.

              • Don’t bother with Retry if you see the timer – ever.
                Just kill it and reload.
                I just tried a Clear Data. Almost, but no joy …
                Was stuck on 1444.6 of 1454mb, the soft re-install got to 1444.4mb and went pop !!

  6. Anyone else having problems with the updates? Server problems?

  7. Since these buildings incorporate the Monorail again, i would love to see a Y rail piece be added to the game. I wish my in-game monorail had branches to Krustyland/Springfield Heights/etc instead of going in a circle.

    • I ended-up splitting my monorail stations so each area has its own, but it would be cool if there was some way for individual systems to connect. It probably would mean losing the additional trains to avoid collisions though.

  8. Is anyone else having issues with their kindle constantly crashing and showing error message about not being able to reach the amazon app store? I play on 5th generation kindle.

    • Mine has started doing that ( also 5th gen, might be time to replace it ). Think it’s a storage issue.
      I’ve had to re-install to update before now as there wasn’t room to just do it.
      It also decided my Home Screen is the place to find my Friends Towns !!
      A Bart Screen is 50/50 whether it’s the Home Screen or the game I get on Retry.

  9. I haven’t been able to log in today? Just spins forever. Anybody else or…?

  10. I used to play TSTO a lot years ago, but lost access to my old mail and passwords, so I started from scratch about a month ago out of boredom. I love the game (even tho ive completed the main storyline billions of times) but I am a little disappointed in the new event “system”. Is there any chance that EA would change the event system from repetitive as it is now to how it used to be? tbh, i would prefer that even if it takes much more downtime between the events than this…. i still appreciate the new content tho since these days many mobile games are starting to sleep on adding new content

  11. I only have 14 gold road tiles and the price for the 15th tile has jumped to 500M

    Is that the cost limit or is there more incremental jumps still to come

Leave a Reply