Town Portrait Bug Thread

Hey Howdy Hey Tappers!

So last night Town Portrait was introduced to our games…provided you downloaded the app store update…and as is common with new features in this game, this one has a few bugs to work out.  MANY players are having great success once they get the hang of it, still, others are having some issues.  In particular, loads of problems I’m seeing for players who use Amazon devices.

So here’s one single post to list all of your bugs/issues/questions about Town Portrait.  This way they’re in one place, EA can view your problems and if it’s fixable others in the community can assist.  So if you’re having issues with your Town Portrait feature post your comment here about it, and we’ll see how we all can help! 🙂

143 responses to “Town Portrait Bug Thread

  1. Does someone know if there a way to upload the town portrait to the Flickr Addicts group even if I don’t want to sign in/register?

  2. Wooo Wooo! finally got it to work.

    • How and what device are you using ??? Oo.

      Would you mind telling me. Oo.

      Mine is still stuck zoomed in. Oo.

      • iPhone X been saying not enough disk space but it all of a sudden worked. Figured almost 2G should be enough. Surprisingly clear photo. Uploaded it to the Flickr thread. Hope they fix the bug soon. Seeing the complete thing puts all the time spent into perspective.

  3. stephaniemae815

    I’m zoomed in – waiting for a patch/update/fix. Fire 8 here, I’ve uninstalled and reinstalled more than once with no luck. I’ve also contacted EA. Twice. I haven’t heard anything back yet. I just wanted to share with the others here, let you guys know what I’ve tried so far.. good luck to everyone.

  4. Have not been given the camera. Husband and son got it!

  5. When I press the button for my portrait the app closes. I’m on an iPad 4th gen.

    • My iPad 4 also refused making a town portrait, so I did it with Bluestacks on PC.
      Really recommend Bluestacks, works fine and fast, also the resolution is awesome.

      • Hi Ctrl,
        I have searched in vain to find where my Bluestacks town portait is located. Any chance you could point me in the right direction?
        Thank you

  6. I am still having the zoomed out problems, is there no fix yet???? It is zoo annoying!

  7. Amazon Fire tablet zoom update. I was finally contacted by someone who understood the complaint:

    Please let me share that, we are receiving the similar contacts and many of the players are facing the same issue. Good thing is that, this has been brought into the notice of the Studio Team and they are diligently working to fix it as soon as possible. I would request you to wait for some time till this gets through. I know nobody likes to wait however rest assured the team is actively working on it and the issue is being addressed on priority.
    Don’t worry, we will get it sorted out soon. Hope this gets resolved.

    So that sounds more promising. Thanks, forum and Addicts, for allowing me to vent. Like the rest of you, I was a little freaked out at the thought of losing the game after so much work. Take care.

  8. Having some serious issues with the zoom on my Kindle Fire, as my town is fairly big and it now takes 3 times longer to collect everything in! I hate it like this!! Can’t use capture either as keeps saying I don’t have enough memory. Been playing for a few years and spent a small fortune, but almost ready to give up unless issues are fixed 😢

  9. I love the portrait!!! I couldn’t get it to work on my tablet (android, probably not enough memory), so I installed the game on my phone (samsung), got a picture there and emailed it to my desktop computer so I could see better. I just love it!

  10. I’m experiencing the zoom problem on my Fire 7. I contacted EA help and here is their response:

    New knowledge has just come in about the recent problem with the game.
    We apologize for this inconvenience; as of this moment there are no plans from studio to adjust this, since the zoom limit was only slightly changed.

    Only slightly changed… So it looks like EA is going to be lazy about this. I filled out a very scathing survey, but I’m not sure what else can be done. Maybe if enough of us complain…?

    • The first rule of TSTO support…never trust what EA customer service tells you

    • I am having the same problem on my Fire tablet. The zoom in is so BIG that you can hardly go around and tap and collect anything. The game is barely playable this way! I truly believed that EA was going to take this issue seriously and resolve it and I am very disheartened to hear this response. I guess I am going to have to take it up with them too. Not Happy!!!

    • That response makes it sound like they don’t even really understand the problem (which I have on my Fire 7 as well). I don’t know what the “zoom limit” has to do with anything – the issue is that the zoom is now permanently stuck zoomed in 100%, and can no longer be adjusted back out, not even one iota.

    • I’ve complained (to EA). I’m being patient for now however, I will not be able to continue playing if it stays this way. I’m going to email EA again for good measure. Thanks for posting.

  11. It’s only been one day, but still no Town Portrait anything. Just checking in…

  12. I love the portrait concept if I could only get it to work! Wish I knew how to post pics on here!

  13. So I’m not the only person that ends up with a very low res final image? Sure it looks fine in native resolution, but zoom in to look at any detail and it’s pixel city.
    Running an iPad Pro with latest iOS, so if that can’t output in a higher resolution then what can!?

  14. As soon as I press “capture” the iPad crashes – plenty of space.

  15. Super zoom is a real sod, hopefully they’ll sort it out as you can’t get an overview to build new areas

  16. iPhone 8 Plus encountered error please try again! Got latest iOS update lots of storage no open apps ! Tried numerous times to no avail

  17. Works great on my Android Lg G7.

    * Only issue was I couldn’t let my screen turn off or sleep.* If I did sleep while processing the portrait it failed.

    Extended screen/ sleep time to 15 minutes and let it do it’s thing. Worked fine after that change.

  18. I’m playing on a iPhone 7 Plus and every time I try save my town portrait, it says there was an “unknown error”. Is anyone else getting this message?

  19. Can’t save to IPad or IPhone – same issue – encountered problem – try again

  20. Seems it doesn’t work for all the older players with big towns. Mine is 42.3MB and I also get the error message: “Town Portrait encountered an unknown issue. Please try again.”

  21. Doh!!!!! Can’t play game like this, too close help, someone, ugh!

  22. Kindel, same problem, super close ugh!!!!!!! Can’t make smaller. Stuck on zoom in!! Help!!!

  23. Same here with the frustrating massive close up glitch. I can’t exactly say “zoomed in” because it can fractionally “zoom out”. Unfortunately, zoom out is not much better. The game is ridiculously close up. Task bar so small. Dialog bubbles tiny tiny tiny, as are the ” ready to collect icons above buildings, characters. But seriously, being only able to see one and a half buildings at a time is just disheartening.

    I’m thinking one of the possibilities being considered is it may be more than just an update glitch, and maybe related to the new camera/photo feature…? Just in case it is, adding my info related to that.

    Opened the game after the update. Got the pop up for the new feature. Clicked on the icon to check it out. Balked at the “Permissions Screen” and decided I would exit the feature check it out later, start the event, (and go back to sleep). This is when I noticed the the screen was in extreme close up mode! Tried to zoom out, but it made only a nano fraction of a difference.

    • Oh… duh… we noticed this so far on Kindle HD Fire 8. Gotta check with the family who still play their accounts on the Fire 7s when they get home.

    • Same problems. Actually unplayable. The toothchipper is bigger than the screen. Hopefully they fix it. 6 years, 385 characters, and I have no idea how many buildings, can’t give in now.

    • Does anyone know what is happening with this zoom problem cause it makes KEN farming impossible for me now and this has to be the WORSE problem I have ever experienced in the game to date

    • Same here! So hard to play with it all zoomed in. Always wished it could zoom out even farther than it did. This is the extreme opposite of that wish. Hope they can fix it soon.

  24. I will add to the rest. On my kindle I can not zoom out and all of game options are super small. Thanks in advance for the help!

  25. My first screenshot I took 12 hours ago was large, 36 MB. Now I took a new one and it only has a size of 11 MB and is very low res. The Simpson’s And Flander’s House are missing in all of my shots.

  26. *Me still over here waiting for a search feature for my inventory*

  27. Amazon Fire Tablet 7 — I can’t zoom out. Very frustrating.

  28. Phyllis Pintner

    I have a kindle and am unable to get out of zoom mode since the new update.

  29. On both iPhone and iPad, both with plenty of storage space, I get as far as “saving to device” before “Town Portrait encountered an unknown issue. Please try again.”

  30. Downloaded the photo on my Kindle 10 (7th Gen) with plenty of memory.
    Although, the result is quite grainy when I attempt enlarge the view to see details. Are the results of the photos on other devices the same.

Leave a Reply